EVMS MD Program

Laptop Computing Requirements:

Netbooks, iPads and other tablets are not viable choices to fulfill the computing requirement.

Windows 7 or Windows 8 is recommended. Mac OSX 10.8 or through 10.10 will likely work but are not officially supported, nor recommended at this time. Windows 10 is not supported.

Browser:

  • Microsoft Internet Explorer version 9, 10, 11
  • Google Chrome 34.0.1847 or higher (supported for NBME exams, not recommended due to compatibility with Silverlight plugin for the EVMS video portal)
  • Firefox 29 or higher
  • Safari version 5.1.9 or higher
  • Do not use beta versions of these browsers

Laptop should not be more than 1 year old, and must have:

  • A warranty and service plan matching the duration of your program
  • Minimum dual core processor
  • Minimum 4 GB of RAM
  • Minimum screen resolution 1024 x 768
  • Wireless card that supports 802.11 a/b/g/n (additional support for 802.11ac is preferred)
  • Microsoft Office 2010 Standard Edition or Higher (this can be purchased through EVMS at a reduced rate after enrollment)
  • Either an internal CD/DVD drive or external CD/DVD drive with USB connection
  • External Storage device for data backup

If you have any questions about computing requirements, please contact the Network Center at comphelp@evms.edu.